Bug 10187 - mmp hangs on "Merging Mono Runtime into app bundle"
Summary: mmp hangs on "Merging Mono Runtime into app bundle"
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: mmp ()
Version: 1.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Sebastien Pouliot
Depends on:
Reported: 2013-02-08 19:11 UTC by Kalid Azad
Modified: 2013-03-07 10:08 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Example project with hangs mmp (1.37 MB, application/zip)
2013-02-08 19:11 UTC, Kalid Azad

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Kalid Azad 2013-02-08 19:11:07 UTC
Created attachment 3351 [details]
Example project with hangs mmp

See http://forums.xamarin.com/discussion/1202/mmp-hangs-during-app-store-build-with-external-file-reference for details.

When packaging for App Store, mmp hangs on "Merging Mono Runtime into app bundle" with the attached project, which includes an external .dylib and .dll. It does not hang when the Packaging options is set to "Don't Link".
Comment 1 Sebastien Pouliot 2013-02-11 11:24:05 UTC
Hello Kalid, it looks like the issue (the hang) is already fixed (but not yet released). Using the lastest (internal) build your test case results in:

error MM2002: Failed to resolve "Shortcut.MASShortcut" reference from "masshortcut, Version=, Culture=neutral, PublicKeyToken=null"
mmp exited with code 1

What happens is that `mmp` is looking for `masshortcut.dll` (based on the assembly fully qualified name) but your assembly (file) name is MASShortcut.dll. For case sensitive file system (like on Macs) this is not the same file.

The good news is that simply renaming your assembly file to masshortcut.dll should fix your issue (it worked for me) or you could rebuild the assembly with the casing you like.
Comment 2 Kalid Azad 2013-02-11 15:36:33 UTC
Thanks Sebastien, that worked! Appreciate the fast response.
Comment 3 Jatin 2013-03-07 10:08:09 UTC
Today, we have verified this issue with the latest builds;

Xamarin.Mac 1.2.43
Xamarin Studio
Mono Framework 2.10.12

And we have observed that today we are successfully able to build and debug the application after including Mono Runtime

Hence closing this issue.